Blog dedicated to Oracle Applications (E-Business Suite) Technology; covers Apps Architecture, Administration and third party bolt-ons to Apps

Wednesday, February 26, 2014

ORA-20010: ERROR: Unable to acquire lock on ad_adop_sessions table. ORA-06512: at "APPS.AD_ZD_ADOP", line 523

I reported this error to Oracle on an SR:

The adop phase=prepare fails before generating any log files. Whatever we get on the screen is what we have. I'll paste it for you again:

$ adop phase=prepare

Enter the APPS password:
Enter the SYSTEM password:
Enter the WLSADMIN password:

Please wait. Validating credentials...


RUN file system context file: $INST_TOP/appl/admin/tsoadba1_alpgetapp049d.xml
PATCH file system context file: $INST_TOP/appl/admin/tsoadba1_alpgetapp049d.xml


************* Start of session *************
version: 12.2.0
started at: Sun Feb 23 2014 20:55:38

APPL_TOP is set to $APPL_TOP
[STATEMENT] Using 48 workers (Default: 48, Recommended maximum limit: 696)
[EVENT] [START 2014/02/23 20:55:48] Verify SSH
Logfile location $INST_TOP/logs/appl/rgf/TXK/verifyssh.log
xml output = $INST_TOP/logs/appl/rgf/TXK/out.xml
[EVENT] [END 2014/02/23 20:55:54] Verify SSH
[ERROR] Failed to execute sql statement :
begin
AD_ZD_ADOP.LOCK_SESSIONS_TABLE('server1',60,0);
end;

[ERROR] SQLPLUS error: buffer=
SQL*Plus: Release 10.1.0.5.0 - Production on Sun Feb 23 20:55:59 2014
Copyright (c) 1982, 2005, Oracle. All rights reserved.
SQL> SQL> Connected.
SQL> begin
*
ERROR at line 1:
ORA-20010: ERROR: Unable to acquire lock on ad_adop_sessions table.
ORA-06512: at "APPS.AD_ZD_ADOP", line 523
ORA-06512: at line 2
Disconnected from Oracle Database 11g Enterprise Edition Release 11.2.0.3.0 - 64bit Production
With the Partitioning, Real Application Clusters, Automatic Storage Management, OLAP,
Data Mining and Real Application Testing options

[UNEXPECTED]Unable to acquire lock on sessions table

adop exiting with status = 2 (Fail)


Oracle asked me to confirm whether I had run adconfig on both run and patch environments. I had forgotten to run adconfig on patch environment.  After running adconfig on the patch environment, I retried and it worked.


No comments: